Sabayon upgrade question

Hello, I have the following preserved libs:

equo pl list
╠ /usr/lib64/libgdbm.so.5.0.0 [libgdbm.so.5:2 -> sys-libs/gdbm-1.14.1]
╠ /usr/lib64/libgdbm.so.5 [libgdbm.so.5:2 -> sys-libs/gdbm-1.14.1]

But also:

equo query installed gdbm
╠ @@ Searching…
╠ @@ Package: sys-libs/gdbm-1.18.1-r1 branch: 5, [system]
╠ Installed: version: 1.18.1-r1 ~ tag: NoTag ~ revision: 0
╠ Slot: 0
╠ Homepage: https://www.gnu.org/software/gdbm/
╠ Description: Standard GNU database libraries
╠ License: GPL-3
╠ Keywords: gdbm
╠ Found: 1 entry

How to know what is the package using sys-libs/gdbm-1.14.1?

Thank you.

Try equo query required libgdbm.so.5

It should show packages requiring the given library name.

Thank you, it was an obsolete version of ruby.

equo query required libgdbm.so.5
╠  @@ Required Packages Search
╠      @@ Package: dev-lang/ruby-2.4.9 branch: 5, [__system__] 
╠          Installed:   version: 2.4.9 ~ tag: NoTag ~ revision: 2
╠          Homepage:    https://www.ruby-lang.org/ 
╠   Library:  libgdbm.so.5
╠   Found:    1 package

I’ve removed it and it’s clean now.