Luet upgrade error after migration

Hello,
I decided to migrate to Mocaccino from Sabayon and used instructions from

After installing luet and repos I run luet upgrade and get the error while downloading mate layer:

 DEBUG (http.go:#103:github.com/mudler/luet/pkg/installer/client.(*HttpClient).DownloadArtifact) Use artifact mate-layers-1.24+44.package.tar.gz from cache.
 X-layers-0.7+4.package.tar.gz -    2% [>                                                        ] (23 MB/1.0 GB, 2.540 MB/s) [9s:6m43s] Failed downloading package mate Artifact integrity check failure: Checksum mismsatch

Is this server or local problem and if the latter, how can I resolve it?

P. S. when I remove cached file mate-layers-1.24+44.package.tar.gz , there is another error:

DEBUG (http.go:#115:github.com/mudler/luet/pkg/installer/client.(*HttpClient).DownloadArtifact) Downloading artifact X-layers-0.7+4.package.tar.gz from https://get.mocaccino.org/mocaccino-desktop-stable
 firmware-layers-1+32.package.tar.gz -   57% [============================>                       ] (190/332 MB, 2.807 MB/s) [1m48s:50s] Failed downloading package mate Error on download artifact: context deadline exceeded (Client.Timeout or context cancellation while reading body)

“Error on download artifact” repeats after installing of the newest liveCD (MocaccinoOS-GNOME-0.20210819.iso) on VM.

Golang handles timeout in a different way. At the moment it’s possible to change the timeout on setting the HTTP_TIMEOUT environment variable before run luet. 0 means no limit.
I think that this will be a configuration option.

Ok, I also found a related piece of code here

Thanks!

I have the same problem with (Client.Timeout or context cancellation while reading body)

How can I set the TIMEOUT to 0?

Thanks in advance.