Good news, installed and working, Bios mode. MocaccinoOS-GNOME-0.20210405.iso

MocaccinoOS-GNOME-0.20210405.iso

Using Vmware workstation pro,


default win 10 x64 settings, 8gb ram, 64gb vnme,
4 cores, (zero virtualization as it gave error in the past)
Usb3.1, display auto + accelerate 3d = enabled.

Booted, isolinux boot loader started, ended up in Gnome gui desktop.

Next test “disks” app and it failed to see the empty 64vm nvme disk.
Opened gparted, created a new msdos ntfs partition.

Opened installer and default settings, zero errors, I could see it was a bit slower copying the files to the partition, no problem.

Reboot into gnome GUI and zero errors in this booting process.

Chrome browser, lan network, settings - display change resolution works 800-600 -> 1280x960 working good.

Fail to partition during install =
MocaccinoOS-DesktopMinimal-0.20210405.iso
MocaccinoOS-Micro-0.20210405.iso
MocaccinoOS-Micro-dev-0.20210405.iso

mocaccino-unattended-installer = same old partition errors, tries to create the partition, then can not save the partition.
Copying process starts, copying to a imaginary destination.

Remove this 3 iso’s and previous above gnome install boots as if nothing was done to the partitions.

I managed to install todays build ,calamares wouldnt build partitions so i USED GPARTED TO BUILD partitions and all went well after thay

I used gparted to partion raw “zero partitions” disk with gparted, then in installer " erase whole disk " and this worked.

Previously if there was a swap partition then during boot the system locked this partition and then installer could not get priority / permission to unmount this swap partition.
The installer then refused to create new partitions as result of the swap partition lock.

Can you confirm if you had a ( raw / empty disk / zero partitions ) or only maybe ntfs / fat32 partitions when you started or if it had swap partition on there / not empty disk.

I had a raw empty disk its an nvme formated to gpt with zero partitions

My initial settings was bios / disabled UEFI.

Tested now with UEFI and installed showed a error with disk partitioning part.

Switched back to bios in vmware workstation pro and voila it worked.

Seems the UEFI is causing issues.

Tried in UEFI with manual gparted parititons /boot/efi swap and root partitions and failed.

UEFI required GPT disklabel type not DOS

Sabayonino, can you make clear this disklabel GPT, is it in the installer or in Gparted or cfdisk in term or ?

  1. Boot into live gnome iso gui desktop.

  2. Select Gparted.

  3. Select empty partition 64gb vm nvme disk.

  4. Gparted, Menu - Device - create new partition table - msdos or GPT. Tested both msdos and gpt.

  5. Click empty disk and create new partititon = NTFS, Apply.

  6. Open Gui installer, move to part of disks, Erase whole disk.

  7. Username ABC, Passwd: 1234, yes root same blah blah, copying files. oops crashed, installer could not create the linux partitions.

Default UEFI enabled in vmware, disk virtual 64gb NVME

Using manual gparted, or manual partition in GUI installer with yes, 128mb fat32 /boot/efi flag=boot or any options of 300 options and variations, results = installer crash in UEFI boot mode.

After this installer failure in UEFI this swap partition artifact remains when I open Gparted and this is easy to delete, vs previous last months testing, it was impossible to delete this swap partition with same UEFI boot process.

In bios boot mode, it works with zero effort, zero extra manual partitions…

Tested the same with SCSI / SATA in Vmware, same results. UEFI is consitantly the broken part, and BIOS boot works without problems.

Tested on laptops hardware with SATA and NVME and same results, UEFI problems, BIOS no problem.

I can understand if the defect of UEFI is in Vmware vs actual hardware in the laptop, surface pro 4 “intel 200 chip” and laptop Clevo intel 300 chip motherboard.

I need to compliment you guys for trying out a system that isn’t even an alpha release. I guess there will be many issues you will bump into, just like we do. Perhaps it is smart to join us on slack where we can discuss all these things?

well my install is upand running like a dream thanks joost for pointing me to flatpak i have most of the apps I use heres my inxi
inxi -F
System:
Host: ron-tobefilledbyoem Kernel: 5.10.20-mocaccino x86_64 bits: 64
Console: tty pts/0 Distro: Gentoo Base System release 2.7
Machine:
Type: Desktop Mobo: ASRock model: X570 Taichi serial: N/A
UEFI: American Megatrends v: P2.00 date: 08/21/2019
CPU:
Info: 8-Core model: AMD Ryzen 7 2700X bits: 64 type: MT MCP cache:
L2: 4 MiB
Speed: 2407 MHz min/max: 2200/3700 MHz Core speeds (MHz): 1: 2407 2: 2415
3: 2936 4: 3001 5: 3000 6: 2998 7: 2817 8: 2796 9: 2994 10: 2411 11: 2407
12: 2411 13: 2408 14: 2414 15: 3003 16: 3005
Graphics:
Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
driver: amdgpu v: kernel
Display: server: X.Org 1.20.10 driver: loaded: amdgpu
note: n/a (using device driver) resolution: 2560x1080~60Hz
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
driver: snd_hda_intel
Device-2: AMD Family 17h HD Audio driver: snd_hda_intel
Device-3: HD Webcam C615 type: USB driver: snd-usb-audio,uvcvideo
Sound Server-1: ALSA v: k5.10.20-mocaccino running: yes
Sound Server-2: PulseAudio v: 13.0 running: yes
Network:
Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
IF: wlp6s0 state: down mac: b6:dd:c4:22:e8:b6
Device-2: Intel I211 Gigabit Network driver: igb
IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: 70:85:c2:d6:78:6c
Bluetooth:
Device-1: N/A type: USB driver: btusb
Report: This feature requires one of these tools: hciconfig/bt-adapter
Drives:
Local Storage: total: 1.59 TiB used: 11.64 GiB (0.7%)
ID-1: /dev/nvme0n1 vendor: Gigabyte model: GP-ASACNE2512GTTDR
size: 476.94 GiB
ID-2: /dev/sda vendor: Intel model: SSDSC2BW240A4 size: 223.57 GiB
ID-3: /dev/sdb vendor: Intel model: SSDSC2BW240A4 size: 223.57 GiB
ID-4: /dev/sdc vendor: Samsung model: SSD 840 EVO 250GB size: 232.89 GiB
ID-5: /dev/sdd vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB
ID-6: /dev/sde vendor: Kingston model: SA400S37240G size: 223.57 GiB
ID-7: /dev/sdf type: USB vendor: SanDisk model: Cruzer Blade
size: 14.32 GiB
Partition:
ID-1: / size: 53.71 GiB used: 10.26 GiB (19.1%) fs: btrfs
dev: /dev/nvme0n1p2
ID-2: /boot/efi size: 511 MiB used: 568 KiB (0.1%) fs: vfat
dev: /dev/nvme0n1p1
ID-3: /home size: 422.73 GiB used: 1.37 GiB (0.3%) fs: btrfs
dev: /dev/nvme0n1p3
Swap:
Alert: No Swap data was found.
Sensors:
Missing: Required tool sensors not installed. Check --recommends
Info:
Processes: 379 Uptime: 2h 34m Memory: 62.74 GiB used: 2.23 GiB (3.6%)
Shell: Bash inxi: 3.3.03
ron-tobefilledbyoem /usr/local/bin #
so far you people have done a magniicent job with this build

@rbrick49

fat32 for /boot/efi must be flagged as EFI System (not msftdata)

Is partitioning schema made by you or by the installer?

PARTITION schema made by me
fat 32 512 mb
/ root 55000 mb
/home rest of drive
no swap
once partitions made I flagged paritions from inside installer

for UEFI , FAT32 partition must be flagged as “boot/esp”

and Partition Table as “GPT”

rbrick49 this is the recipe that no one bothered to mention or presumed we could smell the method.

Boot the latest gnome ISO
MocaccinoOS-GNOME-0.20210413.iso

Example:
Once you are inside the gui desktop, open gparted.

Devices -> Create new partition table select GPT.

Create the 128mb fat 32, 4096 swap, root partition.
Click the green apply button or similar.

Next right click 128mb fat32 select Manage Flags and set the boot option in there, esp will be auto selected.

Close Gparted, and open the installer.

When it gets to the partition / disk usage part of the installation, select manual partition, right click each partition and set /boot/efi swap and /

I presume in this section of the installer you might be able to see the full view of the partition part of the installer and see what is posted above, I could not and it failed to properly resize with this test today.

Click next to proceed and add users and proceed to install.
Reboot and it boots into UEFI and gnome desktop gui.

This is the step I did trying to smell where and how to do this.

Hope this could answer your question.

Confirming MocaccinoOS-GNOME-0.20210413.iso with manual partitioning boots in UEFI and gnome desktop gui as a installed system.

Config:
Vmware pro 15.?? win 10 guest, nvme, usb3.1, 3d acceleration enabled, 8gb ram, 4 core, all virtualization options empty / not selected as it can cause issues.

i dont do vmware install on hard drive

rbrick49, no idea why you want to use vmware like I do to test if you install on hardware. Only mentioned what I was working on so that the team can verify and test.